[4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Bugs are now stored in a bug tracker application. Click on the "Bug reports" link above.

Moderators: Wanderer, Logiqx, Iron Man

Locked
User avatar
Wanderer
Board master
Board master
Posts: 664
Joined: Wed Oct 03, 2001 10:37 am
Location: Milky way, Sol, 3rd planet

[4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Post by Wanderer » Sun Aug 02, 2015 2:57 pm

This crash occurred when creating a new DB from mame 0.163 (x64)

Pasting the image here since there seems to be no way to save or copy/paste the contents of the log file.
RC21Crash.png
RC21Crash.png (98.48 KiB) Viewed 7932 times
- Wanderer -

For Romcenter bug reporting or enhancement requests, click here.

User avatar
Wanderer
Board master
Board master
Posts: 664
Joined: Wed Oct 03, 2001 10:37 am
Location: Milky way, Sol, 3rd planet

Re: [4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Post by Wanderer » Sun Aug 02, 2015 3:16 pm

The second time the database was created but i got the same "illegal dos char" log entries as in this post...
- Wanderer -

For Romcenter bug reporting or enhancement requests, click here.

User avatar
Wanderer
Board master
Board master
Posts: 664
Joined: Wed Oct 03, 2001 10:37 am
Location: Milky way, Sol, 3rd planet

Re: [4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Post by Wanderer » Sun Aug 02, 2015 3:58 pm

Wanderer wrote:The second time the database was created...
Yeah, i wish. The database was indeed created but the same error (as i described in my first post) occurred when i added a rom path. It contains many files, starting from letter A to Z but it loaded files up to a game in letter J, then it wrote "transferring files to database", "analyzing files", "loading games collection", "loading files collection", "Done" and then the error occurred. For some reason it did not add other files even though they do exist in the rom path (letters starting with letters after J).

P.S. #1: more info: it actually loaded 4096 (or 4097) files. The path name in the tab reports (4097 files), under it it says "Selected: (0/4096)"
P.S. #2: hitting "refresh" loaded the whole path normally though...
- Wanderer -

For Romcenter bug reporting or enhancement requests, click here.

User avatar
RomCenter
Author
Author
Posts: 1329
Joined: Fri Sep 28, 2001 12:34 pm
Location: France
Contact:

Re: [4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Post by RomCenter » Wed Sep 09, 2015 8:33 pm

Does it happen everytime ? Does it still happen in b3 ?
Eric - RomCenter developer
http://www.romcenter.com

User avatar
Wanderer
Board master
Board master
Posts: 664
Joined: Wed Oct 03, 2001 10:37 am
Location: Milky way, Sol, 3rd planet

Re: [4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Post by Wanderer » Wed Sep 09, 2015 9:12 pm

RomCenter wrote:Does it still happen in b3 ?
Yup. This time it loaded 3242 files though...

I added the path with drag-n-drop, if that makes any difference.
- Wanderer -

For Romcenter bug reporting or enhancement requests, click here.

User avatar
Wanderer
Board master
Board master
Posts: 664
Joined: Wed Oct 03, 2001 10:37 am
Location: Milky way, Sol, 3rd planet

Re: [4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Post by Wanderer » Wed Sep 09, 2015 11:06 pm

OK, i've tried the following: Create DB, close RC, reopen it, click on the DB tab so it's reloaded and then add the path.
Result: the whole path has been loaded without the error. It seems that the issue occurs only when the path is added immediately after the DB creation (mame 0.163), without closing and reopening RC.

Hope this helps pinpoint the issue.
- Wanderer -

For Romcenter bug reporting or enhancement requests, click here.

Locked

Who is online

Users browsing this forum: No registered users and 2 guests