[4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Bugs are now stored in a bug tracker application. Click on the "Support/Bug reports" link above.

Moderator: Wanderer

Locked
User avatar
Wanderer
Board master
Board master
Posts: 786
Joined: Wed Oct 03, 2001 10:37 am
Location: Milky way

[4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Post by Wanderer »

This crash occurred when creating a new DB from mame 0.163 (x64)

Pasting the image here since there seems to be no way to save or copy/paste the contents of the log file.
RC21Crash.png
RC21Crash.png (98.48 KiB) Viewed 35196 times

User avatar
Wanderer
Board master
Board master
Posts: 786
Joined: Wed Oct 03, 2001 10:37 am
Location: Milky way

Re: [4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Post by Wanderer »

The second time the database was created but i got the same "illegal dos char" log entries as in this post...

User avatar
Wanderer
Board master
Board master
Posts: 786
Joined: Wed Oct 03, 2001 10:37 am
Location: Milky way

Re: [4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Post by Wanderer »

Wanderer wrote:The second time the database was created...
Yeah, i wish. The database was indeed created but the same error (as i described in my first post) occurred when i added a rom path. It contains many files, starting from letter A to Z but it loaded files up to a game in letter J, then it wrote "transferring files to database", "analyzing files", "loading games collection", "loading files collection", "Done" and then the error occurred. For some reason it did not add other files even though they do exist in the rom path (letters starting with letters after J).

P.S. #1: more info: it actually loaded 4096 (or 4097) files. The path name in the tab reports (4097 files), under it it says "Selected: (0/4096)"
P.S. #2: hitting "refresh" loaded the whole path normally though...

User avatar
RomCenter
Author
Author
Posts: 1515
Joined: Fri Sep 28, 2001 12:34 pm
Location: France
Contact:

Re: [4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Post by RomCenter »

Does it happen everytime ? Does it still happen in b3 ?
Eric - RomCenter developer
Report bugs here.

User avatar
Wanderer
Board master
Board master
Posts: 786
Joined: Wed Oct 03, 2001 10:37 am
Location: Milky way

Re: [4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Post by Wanderer »

RomCenter wrote:Does it still happen in b3 ?
Yup. This time it loaded 3242 files though...

I added the path with drag-n-drop, if that makes any difference.

User avatar
Wanderer
Board master
Board master
Posts: 786
Joined: Wed Oct 03, 2001 10:37 am
Location: Milky way

Re: [4.0 b2.1] Crash when creating new DB from mame 0.163 exe (x64)

Post by Wanderer »

OK, i've tried the following: Create DB, close RC, reopen it, click on the DB tab so it's reloaded and then add the path.
Result: the whole path has been loaded without the error. It seems that the issue occurs only when the path is added immediately after the DB creation (mame 0.163), without closing and reopening RC.

Hope this helps pinpoint the issue.

Locked