RomCenter 3.00 alpha 6 released

Romcenter 4 support discussion. Please do not post roms requests or illegal links, posts will be deleted.

Moderators: Wanderer, Logiqx, Iron Man

Forum rules
No roms requests or illegal links
User avatar
RomCenter
Author
Author
Posts: 1294
Joined: Fri Sep 28, 2001 12:34 pm
Location: France
Contact:

RomCenter 3.00 alpha 6 released

Post by RomCenter » Thu Oct 25, 2007 7:47 pm

Version 3.00 alpha 6 released

This is a test only version and should not be used on real files, nor be widely distributed.
Backup your files before using it.


This release fixes a lot of bugs, and add new features.
The database structure changed and you can't use the previously created database files (Next version will include an update process for old databases).

You must create new database from this version.

:arrow: Bugs fixed:
- Vista compatibility improved
- Enable/disable menus sorted out
- Many, many fix on the rom repairing/displaying/updating process
- More delete files sent to bin (can be restored)
- Fixed a bug in arcade.dll when dealing with CHD
- slightly different behaviour of the splash screen
- Unavailable/dropped options are removed from the interface

:arrow: Added:
- 'Close database' menu
- 'Update database' menu
- Old databases are updated to a new version at startup if needed
- Add 'statistics' window (right click on database node for now)
- Update to Database engine 2.0.3
- 'select all, clones, main...' menu are back
- Add 'Test zip files' in fix process.
- New mame xml format
- Installer included

:arrow: Download:
- RomCenter 3.00a6 (3 MB)

Reports bugs and comments in the dev forum.

How to install it:
- unzip in a directory
- run rc300a6.exe

Enjoy
Last edited by RomCenter on Fri Nov 23, 2007 8:33 pm, edited 2 times in total.
Eric - RomCenter developer
http://www.romcenter.com

pachuezama
Galaga
Galaga
Posts: 10
Joined: Fri Feb 02, 2007 11:33 am

Post by pachuezama » Fri Oct 26, 2007 7:08 pm

the download link is for alfa 5 not 6

User avatar
RomCenter
Author
Author
Posts: 1294
Joined: Fri Sep 28, 2001 12:34 pm
Location: France
Contact:

Post by RomCenter » Fri Oct 26, 2007 7:11 pm

Oups... fixed.
Thanks
Eric - RomCenter developer
http://www.romcenter.com

abalone
Galaga
Galaga
Posts: 12
Joined: Sun Nov 26, 2006 7:11 am

Post by abalone » Sat Oct 27, 2007 12:43 pm

I found that both Romcenter 3 alpha 5/6 crash immediately after showing the splash screen.

Romcenter 3 alpha 4 is the last running version on my system

gregor
Pong
Pong
Posts: 2
Joined: Sat Oct 27, 2007 2:25 pm

Post by gregor » Sat Oct 27, 2007 2:33 pm

The bug has to be confirmed on my configuration (Win XP SP2 + all latest updates) :/ Any ideas to fix it ?

ScalNeCuS
Pong
Pong
Posts: 3
Joined: Sun Oct 28, 2007 5:50 pm
Contact:

Post by ScalNeCuS » Sun Oct 28, 2007 5:57 pm

I believe this was also a question in another thread and a problem I also had with Alpha5.
It seems that certain files don't get installed.
You can try to install the latest official version 2.71, and then install the alpha version in the same directory, or you can copy all non-existing files from a 2.71-directory to the alpha-directory.
The last thing is what I did and it solved the problem. Hope this is of some help.

Wessie
Pong
Pong
Posts: 3
Joined: Thu Mar 02, 2006 10:08 am

Post by Wessie » Mon Oct 29, 2007 7:55 am

abalone wrote:I found that both Romcenter 3 alpha 5/6 crash immediately after showing the splash screen.
Me too 5/6 crash immediately :(

I use Win XP PRO SP2 32bit

I gone back to 2.71

gregor
Pong
Pong
Posts: 2
Joined: Sat Oct 27, 2007 2:25 pm

Post by gregor » Mon Oct 29, 2007 6:14 pm

The solution is: in the Romcenter dir rename fbembed.dll to gds32.dll
Until now Romcenter will work !
__if technology is the answer, what was the question ?!
JIL ST msx @ gnu/linux -> http://atariarea.krap.pl/stymulator

User avatar
RomCenter
Author
Author
Posts: 1294
Joined: Fri Sep 28, 2001 12:34 pm
Location: France
Contact:

Post by RomCenter » Thu Nov 08, 2007 7:54 pm

This is correct. I updated the install file. It is now correct.
Eric - RomCenter developer
http://www.romcenter.com

User avatar
RomCenter
Author
Author
Posts: 1294
Joined: Fri Sep 28, 2001 12:34 pm
Location: France
Contact:

Post by RomCenter » Sat Nov 10, 2007 9:46 am

The file mamexml.bat was missing :oops:
I uploaded a new install file with the missing file mamexml included :P
Eric - RomCenter developer
http://www.romcenter.com

davy
Galaga
Galaga
Posts: 22
Joined: Wed Jul 11, 2007 8:57 pm

Post by davy » Sun Nov 11, 2007 12:13 pm

Hi,

can it be that MERGED mode is not yet implemented?
Just cause setting it will be reset to split after reopening preferences...

Cheers
Davy

User avatar
RomCenter
Author
Author
Posts: 1294
Joined: Fri Sep 28, 2001 12:34 pm
Location: France
Contact:

Post by RomCenter » Mon Nov 12, 2007 9:39 pm

All modes are implemented. I tested on 3 pcs and it works on all of them (xp, vista and win 2000).
The settings are stored in the romcenter.ini file in your "my documents/romcenter" folder. Check if it is writable :?
Eric - RomCenter developer
http://www.romcenter.com

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests